首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Node.js
Express
PPA for Ubuntu
ppa:chris-lea/node.js
V2EX  ›  Node.js

前端新人求带

  •  
  •   Oz2011 · 314 天前 · 3157 次点击
    这是一个创建于 314 天前的主题,其中的信息可能已经有所发展或是发生改变。
    来问第一个问题,node 支持 ES6 的 import 了吗? 试了 8.11.2 和 10.4.0 都不行
    11 回复  |  直到 2018-06-11 11:40:58 +08:00
        1
    Oz2011   314 天前
    哈哈 搞定了,我在跟着一个视频学 视频里面用了 import 但是我本地 node 运行会出错,原来是视频里配置了 babel
        2
    throns   314 天前 via iPhone
    用 TypeScript 吧
        3
    wly19960911   314 天前
    直接走框架走起,如果要 babel 你就是前端吧,框架的脚手架已经帮你配置好了很多东西。
        4
    learnshare   314 天前
    Node 好像比较少用 Babel
        5
    onvno   314 天前 via iPhone
    require 很简洁,直接用。不要纠结 import,想用 import 查下就好
        6
    cctv1005s927   314 天前
    deno 走起,大兄弟。
        7
    kefengong   313 天前 via Android
    @cctv1005s927 别误导 deno 距离正式 投入使用还差得远
        8
    Oz2011   313 天前
    哈哈 谢谢各位,我其实是老鸟了,写了 10 多年 C++, 无奈 C++在我这不流行了,准备转行做 web 了 嘿嘿
        9
    Oz2011   313 天前
    @wly19960911 谢谢 你是说 react 之类的吗,我现在还在跟着视频走一遍 JS, 完了就看 react 谢谢
        10
    wly19960911   313 天前
    @Oz2011 #9 嗯。

    我认为入门没必要在构建工具上花更多的时间去学习,实际上各种框架已经给你准备好了项目的模板,配置都准备好了,以后的话有时间一个个了解,使用中也会加深各种配置的印象
        11
    Oz2011   313 天前
    @wly19960911 非常感谢
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2286 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 18ms · UTC 12:41 · PVG 20:41 · LAX 05:41 · JFK 08:41
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1